360doc文章提取器

技术指标源码

文章来源:文章来源 抓取时间:2019-02-11 19:34:10 浏览量:66 作者:martinstock 返回文章列表

技术指标源码   
我顶 字号:

技术指标源码:

1.智能决策系统:(大智慧L-2)

参数名 缺省 最小 最大 步长
N           5     0       999   1
N1       10     0       999   1
N2       20     0       999   1
N3       30     0       999   1

 

A4:=MA(CLOSE,20);
A5:=(CLOSE > MA(CLOSE,5));
A6:=(MA(CLOSE,5) > MA(CLOSE,10));
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
AVX:=(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);T := BARSLAST(DISPSTATUS=1)+1;
T := BARSLAST(DISPSTATUS=1)+1;
HHg := HHV(H, T);
ddg := LLV(L, T);
{Hk := LL-HH; G12 := LL-HK*1.55; }
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股放量下跌,走势明显偏弱,离场观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股缩量下跌,走势偏弱,离场观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股形态良好,强势明显,量能充足,可以继续持有。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股走势趋弱,量能不足,减持大部分筹码。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股形态不佳,注意成交量的变化,但目前不适合参与。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,170,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,170,'该股走势太弱,没有参与价值。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,170,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,170,'如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
DRAWTEXTABS(12,170,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
DRAWTEXTABS(12,170,'可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,170,'大盘形态走坏,重仓者可以减去大部分仓位。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 < V2)) THEN
DRAWTEXTABS(12,170,'大盘缩量调整,注意风险,短线清仓观望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,170,'大盘走势良好,量能理想,可以继续持有强势股。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) THEN
DRAWTEXTABS(12,170,'大盘形态良好,但量能稍显不足,随时准备减仓。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,170,'大盘趋势不明,注意成交量变化,目前不适宜进场。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) THEN
DRAWTEXTABS(12,170,'大盘趋势向下,量能萎缩,不适合进场。 '),COLOR00FF00,LINETHICK3;
{DRAWGBKLAST(C>0,STRIP(RGB(90,90,90),RGB(0,0,0),0));
STICKLINE(C>=O,C,O,8,0),COLOR0000AA;
STICKLINE(C>=O,C,O,6,0),COLOR0000bb ;
STICKLINE(C>=O,C,O,4,0),COLOR0000cc ;
STICKLINE(C>=O,C,O,2,0),COLOR0000ee;
STICKLINE(C>=O,H,L,0,0),COLOR0000ff;
STICKLINE(C<=O,C,O,8,0),Color7B7b00;
STICKLINE(C<=O,C,O,6,0),Color909000;
STICKLINE(C<=O,C,O,4,0),ColorA8a800;
STICKLINE(C<=O,C,O,2,0),COLORcece00;
STICKLINE(C<=O,H,L,0,0),COLORffff00;}
NN:= DISPSTATUS=2;
Mb1:MA(c,n),ColorFFFfff,linethick1,DOTLINE;
Mb2:MA(c,n1),Color00Ffff,linethick1,DOTLINE;
Mb3:MA(c,n2),Color208fff,linethick1,DOTLINE;
Mb4:MA(c,n3),Colorff00ff,linethick0,DOTLINE;
VAR3:=(HIGH < REF(LOW,1));
VAR4:=(LOW > REF(HIGH,1));
DRAWTEXT(VAR3,(HIGH ),'↓QK'),ALIGN0,VALIGN2,COLORffFFff,linethick3;
DRAWTEXT(VAR4,(LOW ),'↑QK'),ALIGN0,VALIGN0,COLOR00ffff,linethick3;
DRAWTEXT(nn,Mb1,''+NUMTOSTRN(Mb1,2)+''),ALIGN0,ColorFFFFFF,LINETHICK1;
DRAWTEXT(nn,Mb2,''+NUMTOSTRN(Mb2,2)+''),ALIGN0,Color00FFFF,LINETHICK1;
DRAWTEXT(nn,Mb3,''+NUMTOSTRN(Mb3,2)+''),ALIGN0,Color208FFF,LINETHICK1;
A1:=REF(HIGH,3)=HHV(HIGH,2*3+1); B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1); D1:=FILTER(C1,3);
A2:=REF(LOW,3)=LLV(LOW,2*3+1); B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1); D2:=FILTER(C2,3);
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);
L2:=LD OR BARSTATUS OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);
UU:=BACKSET(BARSTATUS,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
UU2:=BACKSET(BARSTATUS,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);

 

2.量能饱和度(邱一平麟龙软件)

A:=EMA(AMOUNT/C/1000000,7);
MID :=EMA(A,N);
UPPER:=MID + p/100*STD(A,N);
LOWER:=MID - p/100*STD(A,N);
量能:(A-LOWER)/(UPPER-LOWER),COLOR9999fc;
上限:1,POINTDOT,COLORGREEN;
下限:0,POINTDOT;
STICKLINE(量能>1,1,量能,2,0),COLORRED;
STICKLINE(量能<0,0,量能,2,0),COLORGREEN;

{N10;50;25   P150;300;196};

3.通达信量能饱和度

SAT:=(AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21));
饱和度:IF(SAT>1,1,SAT)*100;
量能≤5:STICKLINE(饱和度<=5,5,饱和度+20,3,0),COLORRED;
量能5~80:STICKLINE((饱和度>5 AND 饱和度< 80),5,饱和度+8,3,0),COLOR5290FF;
量能80~97:STICKLINE((饱和度>80 AND 饱和度< 97),5,饱和度,3,0),COLORFFCC00;
量能≥97:STICKLINE(饱和度>=97,5,饱和度,3,0),COLORGREEN;
DIFF : (EMA(CLOSE,12) - EMA(CLOSE,26))*50,COLORCYAN,LINETHICK2;
DEA  : EMA(DIFF,9),COLORRED,LINETHICK2;

通达信-量能饱和度(副图)

SAT:=(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26);
饱和度:IF(SAT>1,1,SAT)*100,COLORYELLOW;
STICKLINE(C>0 AND ISLASTBAR=1,5,100,10,1),COLORWHITE;
量能≤5:STICKLINE(饱和度<=5 AND ISLASTBAR=1,5,饱和度+20,6,0),COLORRED;
量能5~80:STICKLINE((饱和度>5 AND 饱和度< 80) AND ISLASTBAR=1,5,饱和度+8,6,0),COLOR5290FF;
量能80~97:STICKLINE((饱和度>80 AND 饱和度< 97) AND ISLASTBAR=1,5,饱和度,6,0),COLORFFCC00;
量能≥97:STICKLINE(饱和度>=97 AND ISLASTBAR=1,5,饱和度,8,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1 AND 饱和度,0,'量能饱和度:'+饱和度),COLORFFCCFF;
5,POINTDOT,COLORFFEEBB;
97,POINTDOT,COLORGREEN;

 

改进量能饱和公式,买卖信号更准确。

HH:=MAX(HIGH,REF(CLOSE,1));
LL:=MIN(LOW,REF(CLOSE,1));
AA:=SUM(CLOSE-LL,N1)/SUM(HH-LL,N1);
BB:=SUM(CLOSE-LL,N2)/SUM(HH-LL,N2);
CC:=SUM(CLOSE-LL,N3)/SUM(HH-LL,N3);
B:(AA/N1+BB/N2+CC/N3)*N1*N2*N3/(N1*N2+N2*N3+N1*N3)*100,colorred,LINETHICK2;
S:EMA(b,M),colorcyan,LINETHICK2;
DRAWGBKLAST(v>1,STRIP(RGB(0,0,0),RGB(90,90,90),0));
SAT:=(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N));
饱和度:=IF(SAT>1,1,SAT)*100;
量能≤5:STICKLINE(饱和度<=5,5,饱和度+20,4,0),COLORRED;
量能5~80:STICKLINE((饱和度>5 AND 饱和度< 80),5,饱和度+8,4,0),COLOR5290FF;
量能80~97:STICKLINE((饱和度>80 AND 饱和度< 97),5,饱和度,4,0),COLORFFCC00;
量能≥97:STICKLINE(饱和度>=97,5,饱和度,4,0),COLORGREEN;
IF BARSTATUS=2 and (饱和度) THEN BEGIN DRAWTEXTREL(0,100,'饱和度:'+NUMTOSTRN(饱和度,2)),LINETHICK6,COLORccffcc;end;
DIFF : (EMA(CLOSE,9) - EMA(CLOSE,17))*50,colorred;


参数
n1  4    1    100
n2  8    1    100
n3  16  1    100
m   6    1    100
n    34  1    100


短线;
买入条件:B大于50上穿S,在坑内为有效金叉,可以买入。
卖出条件:饱和达到100,B下破s卖出。

 

麟龙量能饱和公式{{大智慧2}

[free]  
input:N(20,1,100);
SAT:IF((AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100);
STICKLINE(((CLOSE > 0) AND BARSTATUS=2),20,121,40,1),colorFFFFFF;
STICKLINE(((SAT <= 5) AND BARSTATUS=2),21,(20 + SAT),35,0),colorFFFFFF;
STICKLINE((((SAT > 5) AND (SAT <= 20)) AND BARSTATUS=2),21,(20 + SAT),35,0),colorCCFF88;
STICKLINE((((SAT > 20) AND (SAT <= 40)) AND BARSTATUS=2),21,(20 + SAT),35,0),colorFF00FF;
STICKLINE(((SAT > 40) AND BARSTATUS=2),21,(20 + SAT),35,0),color0000FF;
IF BARSTATUS=2 and (SAT) THEN BEGIN DRAWTEXTREL(700,800,'量能饱和度:'+NUMTOSTRN(SAT,0)),LINETHICK6,COLORccffcc;end; DRAWTEXTREL(0,0,'(一)根据量大成头的原理,当【量能饱和度】出现饱和,而当前股价正巧位于一处高价区时,暗示该价位成为该时期峰顶的机率将会大幅增加。'),COLORYELLOW; DRAWTEXTREL(0,100,'(二)根据【爆发力】原理,当【量能饱和度】在一处股价的低价区出现饱和时,该价位便很可能成为一处起涨点。'),COLORYELLOW; 100,POINTDOT,COLORFFFF00; [/free]


 

抄底指标三合一(庄家吸筹+百年大底+量能饱和)

Var1:=IF(YEAR>=2038 AND MONTH>=1,0,1);
Var2:=REF(LOW,1)*Var1;
Var3:=SMA(ABS(LOW-Var2),3,1)/SMA(MAX(LOW-Var2,0),3,1)*100*Var1;
Var4:=EMA(IF(CLOSE*1.3,Var3*10,Var3/10),3)*Var1;
Var5:=LLV(LOW,30)*Var1;
Var6:=HHV(Var4,30)*Var1;
Var7:=IF(MA(CLOSE,58),1,0)*Var1;
Var8:=EMA(IF(LOW<=Var5,(Var4+Var6*2)/2,0),3)/618*Var7*Var1;
吸筹:IF(Var8>100,100,Var8)*Var1,color00ffff;
庄家吸筹:STICKLINE(吸筹>-150,0,吸筹,6,1),color00ffff;
{散户线: 100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),ColorFFFF00,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
庄筹线:EMA(j,6),colorff00ff,LINETHICK2; }
gg:=100*(1-winner(c))>99.8 and v/capital*100<5 and 100*(winner(1.1*c)-winner(0.9*c))<3.9;
百年大底:c>ref(c,1) and ref(gg,1)>0 and var3,,COLORred;
stickline(c>ref(c,1) and ref(gg,1)>0 and var3,0,80,3,0),colorred;
drawtext(c>ref(c,1) and ref(gg,1)>0 and var3,80,'★百年大底★'),COLORred;
量能饱和:IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100),COLORFF00FF;

4.实战验证后的14个精品指标!!!(含源码)

主图指标:
A.{支撑压力}  

Var1:=IF(DATE>=10201201,0,1);
Var2:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);
Var3:=EMA(CLOSE,3);
Var4:=(2*CLOSE+LOW+HIGH)/4*Var1;
Var5:=Var2-Var3;
风险线:EMA(Var4,45)*1.15;
必卖线:EMA(Var4,55)*1.3;
底线:EMA(Var4,40)*0.85;
铁底线:EMA(Var4,88)*0.7,colorred;
成本线:EMA(Var4,55),colorgreen;
持仓:STICKLINE(Var5>=0,Var3,Var2,0.5,0),linethick2;
减仓:STICKLINE(Var5<0,Var3,Var2,0.5,0),linethick2,coloryellow;
价值中枢: (成本线+底线)/2,colorffff00;

B.回吐支撑 飞狐主图源码

清仓:1.66*MA(FORCAST(CLOSE,2),40),colorgreen;
出货:1.36*MA(FORCAST(CLOSE,2),40),COLOR08ffff;
高抛:1.16*MA(FORCAST(CLOSE,2),40),COLORff82ff;
低吸:0.82*MA(FORCAST(CLOSE,2),40),COLORf7e300;
满仓:0.72*MA(FORCAST(CLOSE,2),40),COLOR0000ff;

副图指标

1、操盘手
VAR1:=HHV(HIGH,25);
VAR2:=LLV(LOW,25);
阻力线:EMA((CLOSE-VAR2)/(VAR1-VAR2)*100,20),COLORF0F000,LINETHICK2;
突破线:= EMA((CLOSE-VAR2)/(VAR1-VAR2)*100,5);
操作线:突破线,COLORRED, LINETHICK2;

2、筹码空间

筹码空间:IF(WINNER(CLOSE),WINNER(CLOSE)*100,20),VOLSTICK;
TX80:80,POINTDOT COLORYELLOW;
DX20:20,POINTDOT COLORGREEN;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
K: EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,8),COLORYELLOW ;
D: EMA(0.667*REF(K,1)+0.333*K,2),COLORWHITE;
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((CLOSE-VAR3)/(VAR4-VAR3)*100,3);
VAR6:=(K+VAR5)/2;
VAR7:=EMA(0.667*REF(VAR5,1)+0.333*K,2);
VAR8:=EMA(VAR6,5);
VAR9:EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);


用法:看到黄线K和白线D了吗?

1 当在相对低位时黄线K向上拐突破白线D时,就是介入的时机
2 当在相对高位时黄线K向下拐突破白线D时,就是卖出的时机
3 紫线代表该股的趋势
4 如果你不需要看成交量的话,可以将该指标的第一行"筹码空间:IF(WINNER(CLOSE),WINNER(CLOSE)*100,20),VOLSTICK;"删除,这样可能你看的会更清楚一些.。

3、顶底极品

实价线C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100,COLORWHITE;
A1:=(2*C+H+L)/4;
A2:=LLV(L,34);
A3:=HHV(H,34);
A4:=SMA((HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100-70,9,1)+100;
A5:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
A6:=SMA(SMA(A5,3,1),3,1)+100;
A7:=A6-A4;
底部区域:IF(A7>60,A7-60,0),COLORYELLOW;
持有:STICKLINE(REF(底部区域,1)<底部区域,底部区域,REF(底部区域,1),5,0),COLORF00FF0;
出货:STICKLINE(REF(底部区域,1)>底部区域,底部区域,REF(底部区域,1),5,0),COLOR00FF00;
中线持有:EMA((A1-A2)/(A3-A2)*100,13),COLORBLUE;
中线出货:EMA(0.667*REF(中线持有,1)+0.333*中线持有,2),COLORRED;
STICKLINE(中线持有-中线出货>0,中线持有,中线出货,8,0),COLORBLUE;
STICKLINE(中线持有-中线出货<0,中线持有,中线出货,8,0),COLORRED;

4、“波段确定”源码

q1:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100;
q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
q3:=SMA(q2, 9, 1);
q4:=SMA(q3, 3, 1);
aa:3*q3-2*q4, ,color1010FF;
q5:=aa>1*REF(aa, 1);
q6:=LLVBARS(LOW, 50);
q7:=SUM(VOL, q6);
q8:=HHVBARS(HIGH, 50);
q9:=SUM(VOL, q8);
q10:=(CLOSE-REF(OPEN, q8))/REF(OPEN, q8)*100;
q11:=HHV(aa,5);
A1:EMA(q3, 3) , COLORFFDDCC;
A2:EMA(a1, 3) , COLORFFBBCC;
A3:EMA(a2, 3) , COLORFF99CC;
A4:EMA(a3, 3) , COLORFF55CC;
A5:EMA(a4, 3) , COLORFF33CC;
A6:EMA(a5, 3) , COLORFF11CC;
a:EMA(a4, 3), , COLORFF00CC;
DRAWTEXT(CROSS(aa, 20) AND q10<-13,10,'*大底'), color00ff00;
DRAWTEXT(CROSS(aa, a5) AND ref(aa,1)<34,ref(aa,1),'小'), color00ff00;
DRAWTEXT(CROSS(A1, aa) AND ref(aa,1)>80, ref(aa,3), '*顶'), COLOR00ff00;
DRAWTEXT(CROSS(aa, A1) AND q5 AND a1<20 AND q1>9 OR a1>1*REF(a1, 1)
AND q1>4 AND a1<60, 30, '拉'), COLORFFFFCC;

5、波段高手

V11:=MA(C,3)=LLV(MA(C,3),7);
V12:=MA(C,3)<MA(C,5);
V13:=MA(V,5)<MA(V,10)*0.99;
V14:=COUNT(MA(C,1)<REF(C,1),2)=2;
黄:IF(V11 AND V12 AND V13 AND V14,100,50),LINETHICK2;
V1:=MA(C,3)=HHV(MA(C,3),7);
V2:=MA(C,3)>MA(C,5);
V3:=MA(V,5)>MA(V,10)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
卖:IF(V1 AND V2 AND V3 AND V4,50,0),LINETHICK2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),;
D:SMA(K,3,1);

6、趋势指标

趋势线:  3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);  
见底信号:  10;  
买点准备:  IF(趋势线<=10,50,0);

7、四线金叉

EMA30:EMA(C,30),COLORWHITE,LINETHICK2;
EMA60:EMA(C,60),COLORFF00FF;
EMA90:EMA(C,90),COLORYELLOW;
EMA120:EMA(C,120),COLORFFCC66;
EMA250:EMA(C,250),COLORBLUE;
SS:=CROSS(EMA30,EMA60) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA30,EMA120) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA60,EMA90) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA30,EMA90) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 {AND CROSS(EMA30,EMA120)};
DRAWICON(SS,L-0.04,1);
DD:=CROSS(EMA60,EMA90) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA60,EMA250) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA90,EMA120) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA60,EMA120) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(EMA30,EMA250);
{DD:=CROSS(EMA30,EMA250);}
DRAWICON(DD,L-0.04,3);

8、多空能量

VAR0:=(2*CLOSE+HIGH+LOW)/4;
VAR1:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100;
VAR2:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
B:=EMA((VAR0-LLV(LOW,26))/(HHV(HIGH,34)-LLV(LOW,26))*100,16);
短线:SMA(SMA(VAR2,2,1)+3,2,1),COLORYELLOW;
浮筹:EMA(B,4),LINETHICK2,COLORGREEN;
空方:SMA(VAR1,3,1);
DRAWICON(短线>浮筹,0,10);
DRAWICON(短线<浮筹,0,11);
浮筹1:浮筹+0.5,LINETHICK0;
浮筹2:浮筹+1,LINETHICK0;
浮筹3:浮筹+1.5,LINETHICK0;
浮筹4:浮筹+2,LINETHICK0;

9、机构散户

VAR1:=IF((CLOSE > OPEN),((CLOSE - OPEN) * VOL),IF((CLOSE < OPEN),((CLOSE - OPEN) * VOL),0));
VAR2:=IF((CLOSE > REF(CLOSE,1)),((CLOSE - REF(CLOSE,1)) * VOL),IF((CLOSE < REF(CLOSE,1)),((CLOSE - REF(CLOSE,1)) * VOL),0));
VAR3:=IF((OPEN > REF(CLOSE,1)),((OPEN - REF(CLOSE,1)) * VOL),IF((OPEN < REF(CLOSE,1)),((OPEN - REF(CLOSE,1)) * VOL),0));
VAR4:=IF((CLOSE < OPEN),((OPEN - CLOSE) * VOL),IF((CLOSE > OPEN),((OPEN - CLOSE) * VOL),0));
VAR5:=IF((CLOSE < REF(CLOSE,1)),((REF(CLOSE,1) - CLOSE) * VOL),IF((CLOSE > REF(CLOSE,1)),((REF(CLOSE,1) - CLOSE) * VOL),0));
VAR6:=IF((OPEN < REF(CLOSE,1)),((REF(CLOSE,1)-OPEN) * VOL),IF((OPEN > REF(CLOSE,1)),((REF(CLOSE,1) - OPEN) * VOL),0));
VAR7:=(CLOSE > OPEN);
VAR8:=(CLOSE > REF(CLOSE,1));
VAR9:=(OPEN > REF(CLOSE,1));
VARA:=((VAR7 OR VAR8) OR VAR9);
机构SUM(((((VAR1 + VAR2) + VAR3) / 3) / CAPITAL),5) * 1000);
散户SUM(((((VAR4 + VAR5) + VAR6) / 3) / CAPITAL),10) * 1000);
系数:EMA((((((((COUNT(VAR8,12) / 12) + (COUNT(VAR7,12) / 12)) + (COUNT(VAR9,12) / 12)) / 3) * MA(机构,5)) * 2) * 1.1),2),COLORRED;
平衡:0,POINTDOT,COLORGREEN;

10、出手就赢

VAR2:=REF(LOW,1);VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);VAR5:=LLV(LOW,30);VAR6:=HHV(VAR4,30);VAR7:=IF(MA(CLOSE,58),1,0);VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;VAR9:=IF(VAR8>100,100,VAR8);STICKLINE(VAR9>-150,0,VAR9,3,0), , COLORFF00FF;底部吸筹指标: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100, , COLOR00FF00;STICKLINE(CROSS(底部吸筹指标,-24),100,0,6,0), , COLORFFFFFF;先知: (CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100, , COLORFF00FF;可能放量拉升: IF(CROSS(底部吸筹指标,-24),1,0), , COLORFFFFFF;短线获利:STICKLINE(REF("KDJ.J",1)<0 AND "KDJ.J">0,60,0,2,0),COLOR0000FF;VARK1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;VARK2:=REVERSE(VARK1);VARK3:=SMA(VARK1,3,1);波段王:=SMA(VARK3,3,1), , COLORRED,LINETHICK2;波段鬼:=SMA(波段王,2.5,1),COLORYELLOW,LINETHICK2;趋势线: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1), ,COLORFF6666,LINETHICK2;RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; K1:=SMA(RSV9,3,1);DK1:=K1-REF(K1,1),COLORSTICK;出手就赢:IF(DK1>7 AND REF(DK1,1)<0 AND (DK1-REF(DK1,1))>9,50,0), STICK,COLORYELLOW;DRAWICON(出手就赢>0,50 ,1);买点准备:IF(趋势线<=10,0,10), COLORFF9933,LINETHICK3;STICKLINE( CROSS(趋势线,10),0,73,6,0), COLOR3366FF,;DRAWTEXT(IF(CROSS(趋势线,10),100,0),68,'抄底'),COLORWHITE ;DRAWTEXT(IF(CROSS(10,趋势线),1,0), 10,'$备钱'),COLOR33FFCC,;DRAWTEXT(REF("KDJ.J",1)<0 AND "KDJ.J">0,50,'短买'),,,,COLORRED ,;DRAWTEXT(CROSS(底部吸筹指标,-24),80,'抄底'),COLORWHITE ,;

11、多空搏弈

VAR1:=1;
VAR2:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100*VAR1;
VAR3:=SMA(VAR2,3,1)*VAR1;
VAR4:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100*VAR1;
VAR5:=SMA(SMA(VAR4,2,1)+3*VAR1,2,1);
WINNER(MA(CLOSE,5))*100, COLORSTICK;
VAR6:=WINNER(MA(CLOSE,5))*100;
VAR7:=HHV(HIGH,9)-LLV(LOW,9);
VAR8:=HHV(HIGH,9)-CLOSE;
VAR9:=CLOSE-LLV(LOW,9);
VARA:=VAR8/VAR7*100-70;
VARB:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VARC:=(2*CLOSE+HIGH+LOW)/4;
VARD:=SMA(VAR9/VAR7*100,3,1);
VARE:=LLV(LOW,26);
VARF:=SMA(VARD,3,1)-SMA(VARA,9,1);
VAR10:=IF(VARF>100,VARF-100,0);
VAR11:=HHV(HIGH,34);
VAR12:=EMA((VARC-VARE)/(VAR11-VARE)*100,16);
VAR13:=EMA(VAR12,4);
VAR14:=LLVBARS(MA(CLOSE,5),30);
压力线: IF(35+EMA(VAR13,80)<100,35+EMA(VAR13,80),100),COLORGREEN;
主力生命: WINNER(MA(CLOSE,5))*100,COLORRED;
多方: SMA(SMA(VAR4,2,1)+3*VAR1,2,1),COLORYELLOW;
浮筹: EMA(VAR12,4),COLORBLUE;
空方: SMA(VAR2,3,1)*VAR1,COLORWHITE;

12、主力蓄势

VAR1:=HHV(HIGH,3);
VAR2:=(IF(WINNER(1.1*CLOSE)<0,0,WINNER(1.1*CLOSE))-IF(WINNER(0.9*CLOSE)<0,0,WINNER(0.9*CLOSE)))*100;
VAR3:=IF(VAR1<0,0,VAR1);
VAR4:=IF(VAR2<0,0,VAR2);
主力动向:  PWINNER(10,VAR3),COLORFF00FF;
主力震仓:  PWINNER(10,VAR4),COLORWHITE;
VAR5:=COST(10);
VAR6:=(CLOSE-VAR5)/VAR5*100;
VAR7:=COUNT(VAR6<-2.05,3);
主力蓄势大本营: IF(VAR7>=3,0.20,0),COLORFFCC66;
风险区域: 1,COLORRED,POINTDOT;
0.9,COLOR0099FF,POINTDOT;
VAR8:=(CLOSE-MA(CLOSE,10))/STD(CLOSE,35)*0.3;
强弱动向: EMA(VAR8,18),COLOR00FF00;
VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR10:=SMA(VAR9,3,1);
VAR11:=SMA(VAR10,3,1),COLOR0000FF;
VAR12:=SMA(VAR11,3,1),COLOR00FFFF;
金叉:IF(CROSS(VAR11,VAR12) AND (VAR11<40),0.9,0),COLOR0000FF,LINETHICK2;
STICKLINE(金叉,0,0.5,8,0),COLORRED;
STICKLINE(金叉,0.45,0.6,2,0),COLORRED;
 
 
5.号称天下第一无人能比的公式源码(大智慧)
Var1:=EMA(WINNER((LOW+HIGH)/2),10)*100;
Var2:=EMA(WINNER(CLOSE),21)*100;
Var3:=EMA(WINNER(CLOSE),34)*100;
Var4:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
X1: SMA(Var4,5,1),COLOR00ff00 ,linethick2  ;
X2: SMA(X1,3,1),,COLORYELLOW ,linethick2  ;
X3: 3*X1-2*X2, ,COLORf00ff0  ,linethick2 ;
Var5:=EMA(CLOSE,26)-EMA(CLOSE,12);
Var6:=EMA(Var5,9)*8;
Var7:=2*(Var5-Var6);
80,,COLORGREEN ,POINTDOT;
20, ,COLORGREEN,POINTDOT;
Var8:=CLOSE*50/100;
Var9:=MA(Var8,30)*0.83;
VarA:=MA(Var8/Var9,3);
IF(VarA<103/100,20,0),linethick2,color23ACFF;
  LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4,1)/
SMA(ABS(CLOSE-LC),4,1)*100;
顶部雷达:CROSS(80,RSI)*100,,LINETHICK2, colorf0f000;
{DRAWTEXT(CROSS(80,RSI) , 100,'★见顶 ')colorgreen;}
Varb:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
Varc:=SMA(MAX(CLOSE-LC,0),10,1)/SMA(ABS(CLOSE-LC),10,1)*100;
Vard:=BARSCOUNT(CLOSE);
底部雷达:(Varb< 20 AND Varc< 25 AND Vard> 50)*100, ,linethick2 ,coloryellow;
{DRAWTEXT(CROSS(100,底部雷达) ,100,'☆底 '), , linethick1 COLORMAGENTA;}Var11:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE < REF(CLOSE,1),0-VOL,0)),0);
Var12:=SUMBARS(VOL,CAPITAL);
Var13:=IF(CLOSE>LLV(CLOSE,Var12),1,-1)*IF(Var11>LLV(Var11,Var12),1,-1);
Var14:=IF(Var13=-1,1,0);
Var15:=COUNT(Var14=1,8)>2;
Var16:=SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100;
Var17:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/Var16);
Var18:=(CLOSE-Var17)/Var17*100<-15;
Var19:=(CLOSE-MIN(REF(CLOSE,5)*0.865,REF(CLOSE,21)*0.772))/CLOSE<0.05;
RSW: Var18 AND Var19 AND Var15,COLORRED;
DRAWTEXT(RSW>0 AND REF(RSW,1)=0,50,'出击止盈'),COLORRED;
Var88:=MA(CLOSE,27);
Var98:=(CLOSE-Var88)/Var88*100;
VarA8:=MA(Var98,2);
VarB8:=BARSLAST(CROSS(-10,VarA8)=1);
VarC8:=BARSLAST(CROSS(VarA8,10)=1);
VarD8:=VarA8<-10 AND VarB8>3;
VarE8:=VarA8>10 AND VarC8>3;
黄金坑: IF(VarD8,VarA8,0),LINESTICK ,LINETHICK2, COLORYELLOW;
a1:=REF(CLOSE,2);
a2:=SMA(MAX(CLOSE-a1,0),7,1)/SMA(ABS(CLOSE-a1),7,1)*100;
波段介入点:IF(a2<19,19,0);
LC5:=REF(CLOSE,1);RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(RSI,11),LOW,'低吸 '),COLORRED;var78:=ema(amount/vol/100,3);  BB10:=100*(c-cost(10))/cost(10);
BB1:=(close-llv(low,28))/(hhv(high,28)-llv(low,28))*100;
BB2:=sma(BB1,4,1);
BB3:=sma(BB2,2,1);
BB4:=vol/capital*34;
BB5:=ref(BB4,1);
主力建仓提醒: if(BB3<8.5 and BB2<11,-10,0),colorred;
  Varo2:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
Varo3:=SMA(SMA(Varo2,3,1),3,1);
Varo4:=EMA(Varo3,5);
Varo5:=LLV(LOW,26);
Varo6:=HHV(HIGH,34);
Varo7:=EMA((CLOSE-Varo5)/(Varo6-Varo5)*4,4)*25;
STICKLINE(CROSS(Varo4,10) AND Varo4>10,25,0,8,0),coloryellow;
建仓区: IF((Varo7<6),80,100),linethick2, color00ccff;
 
 技术指标源码(二)

1.MACD超准(通达信)

代码:
SQX:=(C-MA(CLOSE,13))*100;
DIFF:EMA(MA(SQX,7),1),COLORWHITE;
DEA:EMA(DIFF,7),COLORYELLOW;
MACD:(DIFF-DEA)*2,COLORSTICK;
低位金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.1,15,DRAWNULL),COLORYELLOW,LINETHICK4,CROSSDOT;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,28,DRAWNULL),COLORFF00FF,LINETHICK4,CROSSDOT;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),40,DRAWNULL),COLORRED,LINETHICK4,CROSSDOT;
势:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORGREEN;{,COLORRED;}
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),COLORWHITE;
顶背离_:IF(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF
AND CROSS(DEA,DIFF),66,DRAWNULL)
,COLORF08000,LINETHICK4,CROSSDOT;
压:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORFFBB99;
A3:=CROSS(DIFF,DEA) AND DEA<0;
零下二次金叉_:IF(FILTER(COUNT(A3,21)=2,10),53,DRAWNULL)
,COLORWHITE,LINETHICK4,CROSSDOT;
 
 

一个经典指标:超前MACD

前MACD:(用于大智慧.分析家.大智慧L2)


SQX:=(C-MA(CLOSE,13))*100;
diff:EMA(MA(sqx,7),1),COLOR00ffff;
dea:EMA(diff,7),COLORff33ff;macd:(diff-dea)*2,COLORSTICK;
低位金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.1,0.3,0),COLORYELLOW,POINTDOT;
STICKLINE(低位金叉,0,15,8,0),COLORYELLOW;DRAWICON(低位金叉,0.3,1);
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,0.2,0),COLORff00ff,POINTDOT;
STICKLINE(二次金叉,30,15,8,0),COLORff00ff;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),0.1,0),COLORRED,POINTDOT;
STICKLINE(底背离,45,30,8,0),COLORRED;DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),COLORGREEN;
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN;
A3:=CROSS(DIFF,DEA) AND DEA<0;
零下二次金叉:IF(FILTER(COUNT(A3,21)=2,10),0.05,0),COLORWHITE,POINTDOT;
STICKLINE(零下二次金叉,45,60,8,0),COLORWHITE;


做波段抄底的好指标.
它可以看背离.2次金叉等.

用法:
当红,白,紫.黄柱同时出现.
很精确的买点就来临.

2.【第三版】我的操盘手主图和选股公式(不含未来,附用法说明)(飞狐类)

1.编写思路:在上升通道,强势区找出二次买点,做好高抛低吸。
2.用法说明:一、B1为B点发出后的二次买点。
                  二、B1在连续红色持股区域有效。
                  三、B1靠近操作线有效。
3.声明:本指标公式不含未来数据。
4.升版说明:优化主图,增加涨停黄色标志;增加B买入选股公式。
5.第三版说明:增加阻力线、中线、支撑线。
因飞狐升为5.0版本,故未上传第2版的公式,(免得4.9版的朋友埋怨)敬请见谅。
源码如下:
{操盘线主图}
input:M(26,5,300),N(2,0.1,10),P(13,0,300);
中线 :  MA(CLOSE,M),LINEDOT,LINETHICK1,coloryellow;
阻力: (中线 + N*STD(CLOSE,M)),POINTDOT,LINETHICK2,colorgreen;
支撑: (中线 - N*STD(CLOSE,M)),POINTDOT,LINETHICK2,colorred;
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWICON(CROSS(VAR1,MA(VAR2,6)),(LOW * 0.998),8);
DRAWICON(CROSS(MA(VAR2,6),VAR1),(HIGH * 1.013),9);
STICKLINE((VAR1 < MA(VAR2,6)),CLOSE,OPEN,7,1),colorFFFF33;
STICKLINE((VAR1 < MA(VAR2,6)),LOW,(MIN(OPEN,CLOSE) * 1.001),0.6,0),colorFFFF33;
STICKLINE((VAR1 < MA(VAR2,6)),MAX(OPEN,CLOSE),HIGH,0.6,0),colorFFFF33;
STICKLINE((VAR1 > MA(VAR2,6)),OPEN,CLOSE,7,1),color4440FF;
STICKLINE((VAR1 > MA(VAR2,6)),HIGH,MAX(CLOSE,OPEN),0.6,0),color4440FF;
STICKLINE((VAR1 > MA(VAR2,6)),LOW,(MIN(CLOSE,OPEN) * 1.001),0.8,0),color4440FF;
STICKLINE(((OPEN > CLOSE) AND (VAR1 > MA(VAR2,6))),(OPEN * 0.998),(CLOSE * 1.0025),4.5,0),colorFFFF33;
STICKLINE(((OPEN < CLOSE) AND (VAR1 < MA(VAR2,6))),(CLOSE * 0.998),(OPEN * 1.0025),4.5,0),color4440FF;
STICKLINE(((OPEN > CLOSE) AND (VAR1 < MA(VAR2,6))),CLOSE,OPEN,7,0),colorFFFF33;
DRAWTEXT(CROSS(VAR1,MA(VAR2,6)),(LOW * 0.984),'B '),color4440FF;
DRAWTEXT(CROSS(MA(VAR2,6),VAR1),(HIGH * 1.035),'S '),colorFFFF34;
操作线:MA(CLOSE,P),LINETHICK2,colorFF00FF;
aa:=CLOSE/REF(CLOSE,1)>=1.09;
STICKLINE(aa,open,close,8,0),coloryellow;
STICKLINE(aa,low,HIGH,0.5 ,0 ),coloryellow;
MA3:=MA(C,3);
MA5:=MA(C,5);
ZX:=(MA3+MA5)/2;
MA30:=MA(C,30),COLORYELLOW;
QSXS:=MA5>=MA30 AND MA30>REF(MA30,1);
GD:=ZX>=REF(ZX,1) AND REF(ZX,1)<REF(ZX,2);
YB:=C>REF((O-C)/2+C,2);
买:=CROSS(C,ZX) AND (GD OR YB) AND QSXS;
优:=买 AND MA5>REF(MA5,1);
DRAWTEXT(买 OR 优,L*0.99, 'B1'),COLORRED;
{操盘线选股}
MA3:=MA(C,3);
MA5:=MA(C,5);
ZX:=(MA3+MA5)/2;
MA30:=MA(C,30),COLORYELLOW;
QSXS:=MA5>=MA30 AND MA30>REF(MA30,1);
GD:=ZX>=REF(ZX,1) AND REF(ZX,1)<REF(ZX,2);
YB:=C>REF((O-C)/2+C,2);
买:=CROSS(C,ZX) AND (GD OR YB) AND QSXS;
优:=买 AND MA5>REF(MA5,1),linethick2;
B1:买 OR 优;

{B买入选股}
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
B:(CROSS(VAR1,MA(VAR2,6)));

3.量价线(几乎量价线任何一次上穿黑马线都是买入时机)

LS3:=LLV(HIGH,240);
LS4:=100*(CLOSE-LS3)/LS3;
LS5:=REF(LLV(CLOSE,480),1);
LS6:=REF(HHV(CLOSE,480),1);
LS7:=100*(CLOSE-LS5)/(LS6-LS5);LS8:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100;
LS9:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100;
LSA:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100;
LSB:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100;
LSC1:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5);
LSC:=LSC1/4;
LSD:=IF(LSC>23.6,LSC,0);
LSE:=LSC<1;
LSF:=LSD;
LS10:=LS4<LS7 AND LS4<0;
LS11:=1;
LS12:=(HIGH+LOW+CLOSE*2)/4*LS11;
LS13:=EMA(LS12,21);
LS14:=STD(LS12,21);
LS15:=((LS12-LS13)/LS14*100+200)/4*LS11;
LS161:=EMA(LS15,89);
LS16:=(LS161-25)*1.56*LS11;
LS171:=EMA(LS16,5);
LS17:=LS171*1.22*LS11;
LS181:=EMA(LS17,3);
LS18:=LS181*LS11;
LS19:=3*LS17-2*LS18*LS11;
LS1A:=IF(CROSS(LS19,LS17)AND CROSS(LS19,LS18)AND CROSS(LS17,LS18),1,0);
LS1B:=IF(CROSS(LS17,LS19)AND CROSS(LS18,LS19)AND CROSS(LS18,LS17),1,0);
LS1C:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4;
LS1D1:=EMA(CLOSE,2);
LS1D2:=EMA(CLOSE,89);
LS1D:=LS1D1-LS1D2;
LS1E:=EMA(LS1D,30);
LS1F:=(LS1D-LS1E)*20;
LS20:=POW(LS1F,3)*0.1+POW(LS1F,2);
LS21:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
LS22:=EMA(LS21*0.97,3);
LS23:=(HIGH+LOW+CLOSE)/3;
LS24:=(LS23-MA(LS23,14))/(0.015*AVEDEV(LS23,14));
LS25:=IF(LS1F>0.015,LS20,0)/45;
庄拉线:=LS25;
LS261:=EMA(CLOSE,2);
LS262:=EMA(CLOSE,150);
LS26:=LS261-LS262;
LS27:=EMA(LS26,100);
LS28:=2*(LS26-LS27);
LS29:=POW(LS28,3)*0.1+POW(LS28,1);
LS2A:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
LS2B:=EMA(LS2A*0.97,3);
LS2C:=(HIGH+LOW+CLOSE)/3;
LS2D:=(LS2C-MA(LS2C,14))/(0.015*AVEDEV(LS2C,14));
黑马线:IF(LS28>0.1,LS29,0)*5,LINETHICK2;
量价线:(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100,LINETHICK2;
常数线:=0;
X1:LS3;
X2:LS5;
X3:LS6;

偏移:XMA(H,10);观察:MA(H,10);
DRAWICON(LONGCROSS(偏移,观察,1),L*0.9975,1) ;
DRAWICON(LONGCROSS(观察,偏移,1),H*1.0025,2) ;
 
4.[大智慧公式] 早盘10点抓涨停的公式,请大家自己测试 (第二代)
早盘10点抓涨停的公式



早盘10点抓涨停的公式, 10点之后用。(必须实盘的,不能盘后选)。大伙共同研究把

选择涨停股票的基本条件

{ST股票判断、今日停牌股票}
ISST:=STRFIND(STkNAME,UPPERSTR('ST'),1)<>0;
JB:=(ISST=0) and  DYNAINFO(8)>0;

{早盘30分钟,成交量}
B:=DYNAINFO(8);
BV:=REF(V,1);
ZF2:=B/BV*100;

{10点的涨幅}
A:=DYNAINFO(7);
AC1:=REF(C,1);
ZF1:=(A-AC1)/AC1*100;
{当前价格高于开盘价}
D:=A-O;


{股票昨天是涨的}
{K:=REF(C,1)-REF(O,1);}

{5日均线比10日均线高}
KK:=ma(c,5) >ma(c,10) and ma(c,5)>ref(ma(c,5),1);

{5分钟、15分钟、30分钟MACD都出现红柱}

DEA5:="MACD.DEA#min5";
DIFF5:="MACD.DIFF#min5";
d5:=DIFF5-DEA5;

DEA15:="MACD.DEA#min15";
DIFF15:="MACD.DIFF#min15";
d15:=DIFF15-DEA15;

DEA30:="MACD.DEA#min30";
DIFF30:="MACD.DIFF#min30";
d30:=DIFF30-DEA30;

{j:=(d5>0 and d15>0) or (d5>0 and d30>0) or (d15>0 and d30>0);}
j:= (d5>0 and d15>0 and d30>0);


{委买大于委卖}
E:=DYNAINFO(23)-DYNAINFO(22);

{昨天成交量比前天多}
F:=REF(V,1)-REF(V,2);

选股:ZF1<6 and ZF2>30 and JB>0 and j>0 and D>0 and E>0 and F>0 and KK>0;
 
5.(大智慧公式)黄金操盘(主图)
MMS:=MA(SMA((L+H+2*C)/4-REF((L+H+2*C)/4,1),5,1)/SMA(ABS((L+H+2*C)/4-REF((L+H+2*C)/4,1)),5,1)*100,1)+50;
G1:=IF(-MMS>95,0,20);
UOO:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0 AND G1)+1);
KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100));
KS1:=IF(BARSCOUNT(C)=1,C/10000,(1-C/SMA(C,13,1))*100);
趋势线:=EMA(((KS / 10) + EMA(CLOSE,10)),3);
AA:=-100*(趋势线-CLOSE)/趋势线;
AC:=(EMA(AA,5) );
SSL:=EMA(CLOSE,3);
MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);
MM:=MA(MMV,1);
STICKLINE(((SSL>MM)),SSL,MM,0.01,0),COLORRED;
SA:=(MM*0.985);
SS:=(MA(CLOSE,5));
DD:=(MA(CLOSE,13));
GG:=(MA(CLOSE,21));
捞钱手:IF(((SSL>MM)),MM,SA),LINETHICK2,COLORFF00FF;
{IF(SSL<MM,捞钱手,DRAWNULL),LINETHICK2,COLORFFFFFF;}
能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) *4)));
上开:=O;
上收:=C;
上高:=H;
上低:=L;
JJ:=(上开+上高+上低)/3;
A:=EMA(JJ,4);
智能黄金线:A,COLORYELLOW,LINETHICK1;
B:=REF(A,1);
STICKLINE(((SSL<MM)),捞钱手,智能黄金线,0.01,0),COLORFFFF00;
VA1:=EMA(上收,8);
VA2:=EMA(上收,20);
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.978,'★绝佳') ,LINETHICK2,COLORRED;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'★卖');
DRAWTEXT(CROSS(VA1,VA2)AND(C>=O)AND 智能黄金线>REF(智能黄金线,1),VA1*0.97,'★买'),COLOR00FF00;
选手A:=MA(上收,3);
箱顶A:=MA(REF(HHV(上收,6),1),3);
箱底A:=MA(REF(LLV(上收,3),1),3);
T1:=MA(上收,20)>=REF(MA(上收,20),1);
T2:=CROSS(选手A,箱底A) AND 箱顶A/箱底A>100/100 AND T1;
T3:=CROSS(箱顶A,选手A) AND 箱顶A/箱底A>100/100;
选手:=MA(上收,2);
箱顶:MA(REF(HHV(上收,30),1),2),COLOR0000FF,LINETHICK2;
箱底:MA(REF(LLV(上收,30),1),2),COLOR00FF00,LINETHICK2;
T4:=CROSS(选手,箱底) AND 箱顶/箱底>110/100;
T5:=CROSS(箱顶,选手) AND 箱顶/箱底>110/100;
VAR1:=(上收-LLV(上低,27))/(HHV(上高,27)-LLV(上低,27))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
{DRAWTEXT(VAR3 >=VAR4 ,箱顶,'--中期好'),COLOR00FFFF;
DRAWTEXT(VAR3<VAR4 ,箱顶,'--中期坏'),COLORF0F000;
DRAWTEXT(A>B ,箱底,'--短期好'),COLOR00FFFF;
DRAWTEXT(A<B ,箱底,'--短期坏'),COLORF0F000;}
DRAWTEXT(CROSS(VAR3,VAR4)AND(C>=O)AND VAR3<40 AND UOO>0,LOW*0.96,'★'),COLORF00FF0;
STICKLINE(C>=O,C,O,5,0),COLORRED;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,5,0),COLORGREEN;
STICKLINE(C<=O,H,L,0,0),COLORFFFF00;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);   
DRAWTEXT(CROSS(买线,卖线)AND 箱顶>=REF(箱顶,1),LOW*0.95,'★跟'),COLOR00FFFF;
STICKLINE(CROSS(买线,卖线),OPEN,CLOSE,3,0),COLOR00FFFF;


指标中含未来函数,但当其提示“绝佳”和“卖”时那也就离底部和高点不远了,再结合kdj那就能做好了,毕竟谁也不能准确无误地预知顶和底,只能是在底部和顶部就可以了
 
6.(通达信公式)

启动线,看红线,黄线

启动线:SUM(EMA((C+L)/2,2),5)/10.158,COLORRED;
平衡线:LLV(SUM( EMA((C+L)/2,2),5)/10.158,4),COLORMAGENTA;
平台线:LLV(SUM( EMA((C+L)/2,2),5)/10.158,10),COLORFFFFFF;
强弱线:EMA(启动线,21),COLORYELLOW;
STICKLINE(平台线<启动线,启动线,平台线,0.1,0),COLORFF972F;
STICKLINE(平衡线<启动线,启动线,平衡线,0.1,0),COLORRED;
M1:=WINNER( MA(CLOSE,1))*200;
M2:=WINNER(MA(CLOSE,20))*200;
VAR1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(VAR22-VAR23)/VAR24*100;
VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR27:=EMA(VAR25,5);
VAR2A:=((VAR27+VAR26+VAR20)/3+165)/4;
VAR2B:=(EMA(EMA(EMA(VAR2A,15),10),5)-25)*2+VAR21;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2D:=EMA(VAR2C,13);{13}
VAR2E:=(VAR2A+VAR2C)/2/1.1;     
AA:=EMA(VAR2E,3) ;
AA1:=EMA(AA,5);
AA2:=EMA((VAR2B+VAR2D)/2,2);
HH:=MAX(AA,MAX(AA1,AA2))-MIN(AA,MIN(AA1,AA2));
买:=(CROSS(AA,AA1) AND HH<5 AND AA<2),COLORRED,NODRAW;
DQ:=AA<10 AND AA2<10 AND AA1<10;
买点:=(DQ=1 AND HH>REF(HH,1) AND REF(HH,1)<REF(HH,2)),COLORYELLOW,NODRAW;
STICKLINE(AA<10 AND AA2<10 AND AA1<10,强弱线,平台线,4,1);
STICKLINE(买点=1,强弱线,平台线,3,0),COLORYELLOW;
STICKLINE(买=1,强弱线,平台线,4,0),COLORRED;
 
 
    
7.发现底部,勇骑黑马
通达信副图指标:杀庄武器(强力推荐)

指标源码:

A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
{(趋势>80);}
DRAWICON(CROSS(趋势,0),0,1);
{((A09 > 0 AND (趋势<20 OR 趋势>REF(趋势,1)AND 趋势<50))),COLORFFFF00;}
大庄建仓区:=0,LINETHICK0,COLORFFFF00;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
STICKLINE(趋势<=13,0,20,5,0),COLORCC9900;
DRAWTEXT(FILTER(趋势<=13,15),30,'准备数钱\'),COLORCC9900;
STICKLINE(趋势<=13 AND VAR4>13,0,50,3,0),COLOR0099FF;
VAR5:=FILTER((趋势<=13 AND VAR4>13),10);
DRAWTEXT(VAR5,60,'明天买进\'),COLOR0099FF;
STICKLINE(趋势>=90 AND VAR4,0,30,3,0),COLORGRAY;
VAR6:=FILTER((趋势>=90 AND VAR4),10);
DRAWTEXT(VAR6,40,'清仓\'),COLORGRAY;
VAR7:=LLV(LOW,30);
VAR8:=HHV(HIGH,30);
VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;
STICKLINE(VAR9>90,100,105,10,2),COLORRED;
VAR10:=(VAR9-LLV(VAR9,4))/(HHV(VAR9,4)-LLV(VAR9,4))*100;
DRAWTEXT(IF(CROSS(VAR9,VAR10) AND VAR9>87,95,0),88,'小心\'),COLOR00FF00;
DRAWICON(CROSS(90,VAR9),95,9);
VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VAR12:=HHV(VAR11,30)*8;
五指山:EMA(IF(LOW<=VAR7 AND 趋势<40,(VAR11+VAR12),0),3)/618,COLORRED,LINETHICK2;
STICKLINE(五指山>0,0 ,五指山*1.2,8,0 ),COLORRED;
VAR13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
VAR14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趋势线:趋势,COLORFF00FF;

VAR16:=MAX(EMA(VAR13,2)-EMA(VAR14,5),0)*200;
VAR17:=EMA(VAR16,5);
分水岭:VAR17,STICK,COLORFF00FF;
STICKLINE(VAR17<REF(VAR17,1),0,VAR17,1,0),COLOR00FF00;
VAR18:=MA(趋势线,8);
{IF(CROSS(VAR2,VAR18) AND VAR2<15,50,0),COLORRED;}
DRAWTEXT(CROSS(趋势线,VAR2)AND 趋势线>REF(趋势线,1)AND 趋势线<50,50,'全仓买进\'),COLORYELLOW;
8. (此指标在通达信主图中可与操盘手媲美,简单实用,较准确)

江恩八线--主图指标

大盘:=EMA(INDEXC,500)/EMA(C,500);
大盘线:=INDEXC/大盘,LINETHICK1,COLORBLUE;
工作线:EMA(C,14),COLOR00FFFF,LINETHICK1;
一号线:EMA(CLOSE,144),POINTDOT,LINETHICK2,COLOR0000FF;
二号线:EMA(C,25),COLORWHITE,LINETHICK2;
三号线:EMA(C,318),COLOR0000FF,LINETHICK2;
四黑马线:EMA(C,453),CIRCLEDOT,LINETHICK1,COLOR428899;
五号线:EMA(C,550),COLORFFCC66;
六号线:EMA(C,610),LINETHICK2,COLORYELLOW;
七号线:EMA(C,730),COLORBLUE;
八号线:EMA(C,99),POINTDOT,LINETHICK2,COLORWHITE;
DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19)),COLORWHITE;
DEA:=EMA(DIFF,9),COLORF00FF0 ;
MACD:=0.90*(DIFF-DEA), COLORSTICK;
TJ:=(DIFF>=DEA);
TJ1:=(DIFF>=0);
{STICKLINE(TJ,H,L,0,0),COLORYELLOW;}
STICKLINE(TJ,O,C,3,1),COLORYELLOW;
STICKLINE(TJ1 AND TJ,H,L,0,1),COLORF00FF0;
STICKLINE(TJ1 AND TJ,O,C,3,1),COLORF00FF0;
STICKLINE(DIFF<DEA,H,L,0,0),COLORF0F000;
STICKLINE(DIFF<DEA,O,C,3,1),COLORF0F000;
VAR1:=(CLOSE*2+HIGH+LOW)/4;
SK:= EMA(VAR1,13)-EMA(VAR1,73);
SD:= EMA(SK,2);
{DRAWTEXT((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) ,L*0.99,'短线'),COLORFF66FF;}
STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),H,L,0,0),COLORRED;
STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),O,C,3,0),LINETHICK3,COLORRED;
SS:=CROSS(二号线,八号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98
OR CROSS(二号线,三号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98
OR CROSS(二号线,一号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98{AND CROSS(二号线,三号线)};
{DRAWICON(SS,L-0.04,1);}
DD:=CROSS(八号线,一号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98
OR CROSS(八号线,四黑马线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98
OR CROSS(八号线,三号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98
OR CROSS(八号线,三号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98 AND CROSS(二号线,四黑马线);
 
 
 
{江恩八线Z}

七天线:MA(CLOSE,7),COLORYELLOW,LINETHICK2;

一号线:EMA(CLOSE,144),COLOR3399FF;
工作线:EMA(CLOSE,14),COLOR9000F5,LINETHICK2;
二号线:EMA(CLOSE,25);
三号线:EMA(CLOSE,318);
生命线:EMA(CLOSE,453),COLORRED,LINETHICK2;
五号线:EMA(CLOSE,550),COLORFFFF37;
六号线:EMA(CLOSE,610);
七号线:EMA(CLOSE,730);
八号线:EMA(CLOSE,888),COLORF00FF0;
九号线:EMA(CLOSE,99),COLOR53FF53;
DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19));
DEA:=EMA(DIFF,9);
MACD:=0.90*(DIFF-DEA);
TJ:=(DIFF>=DEA);
TJ1:=(DIFF>=0);
{STICKLINE(TJ,H,L,0.5,0),COLORYELLOW;
STICKLINE(TJ,O,C,4,0),COLORYELLOW;
STICKLINE(TJ1 AND TJ,H,L,0.5,0),COLORF00FF0;
STICKLINE(TJ1 AND TJ,O,C,4,1),COLORF00FF0;}
{STICKLINE(DIFF<DEA,H,L,0.5,0),COLORF0F000;
STICKLINE(DIFF<DEA,O,C,4,0),COLORF0F000;}
VAR1:=(CLOSE*2+HIGH+LOW)/4;
SK:= EMA(VAR1,13)-EMA(VAR1,73);
SD:= EMA(SK,2);
DRAWTEXT((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) ,L*0.99,'短线'),COLOR53FF53;
STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),H,L,0.5,0),COLORRED;
STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),O,C,10,1),LINETHICK3,COLORRED;
  
 <

    下载DOC文档