360doc文章提取器

通达信个股叠加大盘K线公式源码

文章来源:文章来源 抓取时间:2019-01-25 21:55:12 浏览量:31 作者:斐睿 返回文章列表

股票公式不明白请查阅:股票公式文件使用以及说明!

通达信个股叠加大盘K线公式源码

{大盘个股K线-通达信版-理想论坛-超级实力}
{通达信对应大盘K线-BY 超级实力}
{自填参数:--【参数P】大于零时采用P的周期作为大盘个股叠加周期,P等于零时采用个股全部上市日期作为叠加周期
M(50,9999,100),P1(0,300,5),P2(0,300,10),P3(0,300,60),N(0,3,0),P(0,99999,0);}
{用法:请在A股下使用,指数和其它品种不显示数据。中小、创业、沪、深大盘分显,采取飞狐源码取3组可调均线可调显示根数(N),默认N为0不显示可调均线}
创业板:=INBLOCK('创业板'),NODRAW;
中小企业:=INBLOCK('中小企业'),NODRAW;
上证A股:=INBLOCK('上证A股'),NODRAW;
深证A股:=INBLOCK('深证A股'),NODRAW;
交易所基金:=INBLOCK('交易所基金'),NODRAW;
开A:=IF(中小企业=1,"399101$O",IF(创业板=1,"399102$O",IF(上证A股=1,"999999$O",IF(深证A股=1,"399001$O",IF(交易所基金=1,"399305$O",0))))),NODRAW;
高A:=IF(中小企业=1,"399101$H",IF(创业板=1,"399102$H",IF(上证A股=1,"999999$H",IF(深证A股=1,"399001$H",IF(交易所基金=1,"399305$H",0))))),NODRAW;
低A:=IF(中小企业=1,"399101$L",IF(创业板=1,"399102$L",IF(上证A股=1,"999999$L",IF(深证A股=1,"399001$L",IF(交易所基金=1,"399305$L",0))))),NODRAW;
收A:=IF(中小企业=1,"399101$C",IF(创业板=1,"399102$C",IF(上证A股=1,"999999$C",IF(深证A股=1,"399001$C",IF(交易所基金=1,"399305$C",0))))),NODRAW;
DPJX:=(开A+高A+低A+收A)/4;{大盘均价}  JX:=(O+H+L+C)/4;{个股均价}
YXZQ1:=IF(中小企业=1 AND REF(DATE,BARSCOUNT(C))<=1050608,BARSLAST(DATE=1050608),IF(创业板=1 AND REF(DATE,BARSCOUNT(C))<=1100820,BARSLAST(DATE=1100820),IF(深证A股=1 AND REF(DATE,BARSCOUNT(C))<=910403,BARSLAST(DATE=910403),BARSCOUNT(C)))),NODRAW;
YXZQ:=IF(P>0 AND P<CONST(BARSCOUNT(C)),IF(P-CURRBARSCOUNT>=0,P-CURRBARSCOUNT,0),YXZQ1),NODRAW;
{大盘个股比例}
BLO:=开A/REF(DPJX,YXZQ)/(O/REF(JX,YXZQ));{大盘开盘比例}
BLH:=高A/REF(DPJX,YXZQ)/(H/REF(JX,YXZQ));{大盘最高比例}
BLL:=低A/REF(DPJX,YXZQ)/(L/REF(JX,YXZQ));{大盘最低比例}
BLC:=收A/REF(DPJX,YXZQ)/(C/REF(JX,YXZQ));{大盘收盘比例}
{模拟大盘数据}
开:BLO*O,NODRAW;
高:BLH*H,NODRAW;
低:BLL*L,NODRAW;
收:BLC*C,NODRAW;
{画背景图}{调节参数N确定背景高度}
DRAWBAND(CONST(HHV(MAX(高,H),M)),RGB(100,100,100),CONST(LLV(MIN(低,L),M)),RGB(50,50,50));
STICKLINE(P=CURRBARSCOUNT,CONST(HHV(MAX(高,H),M)),CONST(LLV(MIN(低,L),M)),0.01,-1),COLORBLUE;{统计周期界限}
DRAWTEXT(CURRBARSCOUNT=100,CONST(LLV(MIN(低,L),M))*1.03,'理想论坛の超级实力'),COLORFFFFCC;
{DRAWKLINE(高,开,低,收),COLORFF9B00;}
{画大盘K线}
STICKLINE(收>=开,高,低,0,0),COLORYELLOW;
STICKLINE(收<开,高,低,0,0),COLORFF55BB;
STICKLINE(收>=开,收,开,4,0),COLOR00AAFF;
STICKLINE(收>=开,收,开,3.3,0),COLOR00BBFF;
STICKLINE(收>=开,收,开,2.2,0),COLOR00CCFF;
STICKLINE(收>=开,收,开,1.65,0),COLOR00DDFF;
STICKLINE(收>=开,收,开,1.1,0),COLOR00EEFF;
STICKLINE(收>=开,收,开,0.55,0),COLOR00FFFF;
STICKLINE(收<开,收,开,4,0),COLORAA00BB;
STICKLINE(收<开,收,开,3.3,0),COLORBB11BB;
STICKLINE(收<开,收,开,2.2,0),COLORCC22BB;
STICKLINE(收<开,收,开,1.65,0),COLORDD33BB;
STICKLINE(收<开,收,开,1.1,0),COLOREE44BB;
STICKLINE(收<开,收,开,0.55,0),COLORFF55BB;
{画个股K线}
STICKLINE(C>=O,L,H,0,0),COLORRED;
STICKLINE(C<O,L,H,0,0),COLORFFFF00;
STICKLINE(1,C,O,3,0),COLOR353500;
STICKLINE(1,C,O,2.8,0),COLOR454500;
STICKLINE(1,C,O,2,0),COLOR555500;
STICKLINE(1,C,O,1.5,0),COLOR656500;
STICKLINE(1,C,O,1,0),COLOR757500;
STICKLINE(1,C,O,0.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.8,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
个股命:MA(C,21),COLORRED,LINETHICK2;
大盘命:MA(收,21),COLOR00FF80,LINETHICK2;
{3组可调均线}
WX:=MA(C,0);
M1:MA(C,P1)*IF(N<1,WX,1);
M2:MA(C,P2)*IF(N<2,WX,1);
M3:MA(C,P3)*IF(N<3,WX,1);
D1:MA(收,P1)*IF(N<1,WX,1);
D2:MA(收,P2)*IF(N<2,WX,1);
D3:MA(收,P3)*IF(N<3,WX,1);

=======================

简化版

{叠加大盘-通达信版-创幻论坛-舍得快乐-只叠加收盘}{自填参数:M(50,9999,100),P(0,99999,0)}
{用法:请在A股、基金下使用,指数和其它品种不显示数据。基金、中小、创业、沪、深大盘分显--【参数P】大于零时采用P的周期作为大盘个股叠加周期,P等于零时采用个股全部上市日期作为叠加周期}
创业板:=INBLOCK('创业板'),NODRAW;
中小企业:=INBLOCK('中小企业'),NODRAW;
上证A股:=INBLOCK('上证A股'),NODRAW;
深证A股:=INBLOCK('深证A股'),NODRAW;
交易所基金:=INBLOCK('交易所基金'),NODRAW;
开:=IF(中小企业=1,"399101$O",IF(创业板=1,"399102$O",IF(上证A股=1,"999999$O",IF(深证A股=1,"399001$O",IF(交易所基金=1,"399305$O",0))))),NODRAW;
高:=IF(中小企业=1,"399101$H",IF(创业板=1,"399102$H",IF(上证A股=1,"999999$H",IF(深证A股=1,"399001$H",IF(交易所基金=1,"399305$H",0))))),NODRAW;
低:=IF(中小企业=1,"399101$L",IF(创业板=1,"399102$L",IF(上证A股=1,"999999$L",IF(深证A股=1,"399001$L",IF(交易所基金=1,"399305$L",0))))),NODRAW;
收:=IF(中小企业=1,"399101$C",IF(创业板=1,"399102$C",IF(上证A股=1,"999999$C",IF(深证A股=1,"399001$C",IF(交易所基金=1,"399305$C",0))))),NODRAW;
DPJX:=(开+高+低+收)/4;
JX:=(O+H+L+C)/4;
YXZQ1:=IF(中小企业=1 AND REF(DATE,BARSCOUNT(C))<=1050608,BARSLAST(DATE=1050608),IF(创业板=1 AND REF(DATE,BARSCOUNT(C))<=1100820,BARSLAST(DATE=1100820),IF(深证A股=1 AND REF(DATE,BARSCOUNT(C))<=910403,BARSLAST(DATE=910403),BARSCOUNT(C)))),NODRAW;
YXZQ:=IF(P>0 AND P<CONST(BARSCOUNT(C)),IF(P-CURRBARSCOUNT>=0,P-CURRBARSCOUNT,0),YXZQ1),NODRAW;
BL:=收/REF(DPJX,YXZQ)/(C/REF(JX,YXZQ));{大盘个股比例}
叠加大盘:BL*C,LINETHICK2;
STICKLINE(P=CURRBARSCOUNT,CONST(HHV(MAX(叠加大盘,H),M)),CONST(LLV(MIN(叠加大盘,L),M)),0,-1),COLORBLUE;{统计周期界限}
DRAWTEXT(CURRBARSCOUNT=100,CONST(LLV(MIN(叠加大盘,L),M))*1.03,'理想论坛の超级实力'),COLORFFFFCC;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
IF(P-CURRBARSCOUNT>=0,叠加大盘,DRAWNULL),LINETHICK2;

通达信个股叠加大盘k线公式源码

    下载DOC文档